Log in

View Full Version : dtec FC help


norcal3737
12-11-2019, 06:47 PM
maybe im just stupid...sooo ill ask here.

i was messing w/ my dtec on my way home, fixing some %'s and all the sudden the real-time playback for all the stuff (like inj. duty cycle, rpm, knock, tps) stops reading and shows - - -.

and then cant adjust anything.
im like ok, ill just shut it off, and restart it. before i do, i notice it reads 'offline' . hmm, never seen that yet? what is it.

so i go to turn it back on, and it stays stuck on the 'Gameboy' screen and wont go past it.
and it also shows a bright orange light on the LED on the side of the gameboy.

i can either think 2 things. 1) the battery on the gameboy died (i thought it recharges when ignition is on?)

if it did die...how was i able to still toggle between the screens, and what not? wouldnt it just blank out?

2) something is unplugged under the dash on the brain.

whats the meaning of the orange light?

any help would be appreciated

eVilcreations
12-11-2019, 09:03 PM
The orange LED on the side of the Gameboy is the "charging" light. Sounds to me like something with the brain for sure......possibly get ahold of turboxs to see if they have a clue, or maybe try a hard reset of the DTEC if that's possible.

Josh

norcal3737
12-11-2019, 09:35 PM
The orange LED on the side of the Gameboy is the "charging" light. Sounds to me like something with the brain for sure......possibly get ahold of turboxs to see if they have a clue, or maybe try a hard reset of the DTEC if that's possible.

Josh


how do i do a hard reset?

i'd love to ask over on the nazi forums, because there's some really knowledgeable people there on the dtec...but i got banned by efool :DOH:


maybe i should contact turboxs directly?

eVilcreations
12-11-2019, 10:00 PM
how do i do a hard reset?

i'd love to ask over on the nazi forums, because there's some really knowledgeable people there on the dtec...but i got banned by efool :DOH:


maybe i should contact turboxs directly?

I did a search about the hard reset, and really didn't come up with anything useful. I would contact TurboXS direct and see what they have to say.......

Also make sure you check all your connections, solders, and plugs for security before proceeding with any other troubleshooting.......if you haven't already of course.....


Josh

norcal3737
12-12-2019, 12:09 AM
I did a search about the hard reset, and really didn't come up with anything useful. I would contact TurboXS direct and see what they have to say.......

Also make sure you check all your connections, solders, and plugs for security before proceeding with any other troubleshooting.......if you haven't already of course.....


Josh

well, i just got her installed yesterday and everything was working fine until this point today. we double/triple checked all solder connections and everything came out good.

i left for school tonight and wont be back until thursday night. the anticipation of wanting to know whats wrong is going to kill me. lol.

whiteACRsrt05
12-12-2019, 09:34 AM
From what i have found your chip board took a dump..... You need to send the "brain" back to txs and they will ship another one out to you...... If it reads off line then I would say 75% THAT ITS THE BRAIN. :thumb:

norcal3737
12-12-2019, 11:17 AM
From what i have found your chip board took a dump..... You need to send the "brain" back to txs and they will ship another one out to you...... If it reads off line then I would say 75% THAT ITS THE BRAIN. :thumb:



:gcry:

do you have a source where i can read that?
i just got the thing installed!!

does this happen on a daily basis?

whiteACRsrt05
12-12-2019, 11:44 AM
I read it on the e-tool site a while back i tried a quick search but im busy at work and couldnt check all 11,000 threads yet......
I do suggest unhooking the battery for a little bit just to make sure it just did not freeze up on ya that happens quite often... If that dont help then go with my original statement that the brain died

evil_2
12-12-2019, 12:32 PM
hhhmmm...all these problems with dtecs make me glad i didnt buy one

|